Criar-reagir-aplicativo está instalado interno com dependências quebradas?

Eu estou aprendendo a reagir e ter um problema com criam-reagir-app util. Uma vez eu criei um novo projeto com o criar-reagir-app e escreveu "a ngp lista --profundidade 0" - eu tenho os seguintes erros:

PS C:\Users\dmitriiz\Documents\Sources\Sandbox\lovereact> npm list --depth 0
[email protected] C:\Users\dmitriiz\Documents\Sources\Sandbox\lovereact
+-- [email protected]
+-- [email protected]
`-- [email protected]

npm ERR! peer dep missing: [email protected]^5.0.0, required by @typescript-eslint/[email protected]
npm ERR! peer dep missing: [email protected]^5.0.0, required by @typescript-eslint/[email protected]
npm ERR! peer dep missing: [email protected]>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta, required by [email protected]

1) criar o aplicativo como: npx criar-reagir-app lovereact (fechar outras maneiras - mesmo resultado)

2) não consigo instalar mais nada (como você pode ver na lista acima)

3) Na minha lista global de eu ter apenas npm pacote instalado:

C:\Users\dmitriiz\AppData\Roaming\npm
`-- [email protected]
4) My Node version is 10.14.1

5) eu tentei instalar o criar-reagir-aplicação a nível global e usar a instância global, tentei instalar pacotes diferentes para curar os erros, e algumas outras coisas - nada ajuda.

6) Talvez algo de errado com criam-reagir-app? Por exemplo este ficheiro:

lovereact\node_modules\@typescript-eslint\eslint-plugin\package.json

tem este eslint ponto dep:

"peerDependencies": {
    "@typescript-eslint/parser": "^1.9.0",
    "eslint": "^5.0.0"
  },

enquanto ao mesmo tempo, o lovereact\[email protected] pasta não tem qualquer eslint pacote dentro. Ok, talvez ele deve tomar a "eslint" pacote a partir do nível anterior em lovereact\node_modules\ ? Sim, criar-reagir-app já tem eslint pacote e da sua versão 6.4.0

"_id": "[email protected]",

que definitivamente devem estar em conformidade com o "eslint": "^5.0.0" requisito, não é?

Então, por favor, diga o que há de errado comigo ou com cria-reagir-app? Eu não posso encontrar exatamente o mesmo problema na Internet (incluindo ASSIM), mas ao mesmo tempo eu vejo que algo de errado com criam-reagir aplicativo de instalação padrão. Ou talvez eu perca alguma coisa?

Obrigado antecipadamente!

0
2019-09-18 21:46:27
origem
0 respostas

Veja mais perguntas por marcas